Introduction to HTML & CSS
File and Folder Management in the Windows Operating System

Unit 1
Lesson 1-2

In This Lesson
What file management?
Why is it important?
The desktop metaphor?
What is File Explorer?
Demos!

What is File Management.
Creating files and folders.
Renaming files and folders.
Copying files and folders.
Moving files and folders.
Deleting files and folders.
Understanding the file system.

• As the second part of Lesson 1, we are going to have a
quick review of Windows 10 file management.
• We will look at why file management is important to
us as web developers.
• In order to understand the file system better we will
look at the bigger picture of how Windows and almost
all computer operating systems make all those 0s and
1s into something we can comprehend.
• We will look and Windows File Explorer and gain
some insight as to what all those icons around the
window can do for us.
• Lastly, we will practice some file management skills
that are necessary to any career that uses a computer
and we will have some step by step directions at the
end of the lesson to help us along.

• The short answer is, file management is the ability to
do all of the above actions.
• The last bullet point is the key to file management.
Having a good understanding of the file system that
the operating system you are working with uses, is
critical.
• There are many operating systems, such as MacOS,
Linux, Android, Chrome, BSD and many more. We
will be using Windows and specifically Windows 10.

Why File Management is Important
An important job skill for anyone
Critical for a web developer
Necessary in all operating systems
Windows is a good starting place

Before the GUI
GUI – Graphical User Interface
Helps us navigate the file system
Before the GUI was CLI
GUI – faster and smarter

• As a web developer, and also in many other careers
both directly and indirectly related to computers,
being proficient at these procedures is a skill that is
developed through practice. Having this ability is a
huge employment advantage. This can hold true for
so many job requirements it is impossible to list them
all here.
• As a web developer, file management is critical. You
will need to have a keen understanding of the items
listed on the previous slide, because you may well be
involved the creating the directory or folder structure
for a website. Remember that a website is just a
collection of files which are inside of folders that live
on a computer.
• Although file management is necessary in all
operating systems, we can’t study them all here. I
think Windows is a good OS to use for career
advancement. In fact, probably the best OS to use
because currently Microsoft Windows has over an
88% share of the market on desktop and laptop
computers. This means when you go to work, the
company you work for will be highly likely to be
using Windows.

• The computer’s operating system does much more
than handle file and folder management. The OS
actually does all the software communication with all
the hardware that makes up a computer. It tells the
mouse how to move. It tells the monitor how to
display everything. It tells the printer how to print a
document. And much, much more. At the very heart
of the computer the language used is simply on or off.
Billions of switches in the computer turn off or on,
billions of times a second, just like a light switch. The
computer translates this off or on state as the numbers
0 or 1. We would not be able to be productive at all if
we had to deal with just zeros and ones. As the
computer builds layer upon layer of programming, it
translates those two numbers or two states of off and
on into the GUI we know as Windows or MacOS or
even the OS you have on your phone.
• This GUI helps us work by giving us a more human
picture of what is happening below the surface in a
digital world that is very complicated.
• The CLI or command line interface was a dark screen
with white text. Sometimes other colors were used,

such as green text. It is still used, but we will
concentrate on Windows.
• The Windows GUI enables us to work faster and
smarter. In the command line it was necessary to
remember commands while in a GUI the commands
are visible icons and words that remind us of which
needed command to use.

CLI

The Desktop Metaphor

The Windows Desktop

• A command line interface looks like this and requires
typing of a command for each action. This is what it
took to navigate to the pictures folder and open a
picture. And this gif is much faster than I can type.

The desktop metaphor is a computer interface
conceptual metaphor of a desk. It is a set of unifying
concepts used by graphical user interfaces to help users
interact more easily with the computer. The desktop
metaphor was first introduced by at Xerox Palo Alto
Research Center in 1970.
The idea is that the computer monitor is a desk. An open
document is like a paper which is part of a file that
comes from a folder. Like most desks, you also have
applications which are similar to desktop appliances,
such as a clock, a calculator, a map, or a dictionary. In
your desk and on your desktop, you can store pictures,
notes, or maybe business contacts. The desk drawers are
like file cabinets where you store files and folders for
safe keeping. And the Recycle Bin is like a trans can for
discards.
After starting Windows, you will find yourself on the
Windows Desktop.

Recy cle Bin

Taskbar
Start Menu

Task View



ALT+TAB

System
Tray

Cortana Search

+Q

Quick Launch
Programs

Running
Programs

Open File Explorer
1. Go to Cortana Search
2. Type: File Explorer
3. Right-click and choose Add to Taskbar
4. Left-click to Open

Starting in the upper left corner and moving counterclockwise.
• The Recycle Bin: Highlight an object and press the
Delete key or drag and drop objects to it.
• Start: Click the Start Menu icon or press the Windows
key.
• Search: Click the Cortana search box or press
Windows and the letter Q at the same time.
• Task View: Click the icon or press Windows + TAB or
ALT + TAB
• Quick Launch Programs: Search for any program and
when Cortana finds it, right-click on it and choose
Add to Taskbar.
• Running programs: Any programs you have running
show in the Taskbar with a blue underline.
• The Taskbar runs across the bottom of the screen by
default, but you can customize it and place it
anywhere.
• The System Tray contains the Notification Area, the
Clock, and icons that provide access to several system
resources.

The main tool for file management in Windows is File
Explorer (formerly called Windows Explorer). To open
File Explorer we go to the Cortana search box, next to the
Start Menu button in the Windows taskbar. In Cortana
search for File Explorer. Add it to the Taskbar for future
easy access and open it.

Quick Access To olbar
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File Explorer
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So here is a quick primer on the File Explorer window
and how it works. This is not meant to be a complete
tutorial. It is an overview. But understanding some basic
information will help navigate this tool.
Starting at the top and this time going clockwise.
Quick Access Toolbar: You can customize this toolbar
with a few of the most often used file commands.
Current Folder Name: Self-explanatory. The folder you
are displaying the contents of.
The Ribbon: Kind of the command center of the File
Explorer. You change the ribbon, by clicking the ribbon
tabs. We will investigate many of the features of the
ribbon as we go along. There are some keys to helping us
remember how to use Window’s ribbons, which are now
used in most Windows programs and the OS itself.
In File Explorer those keys are:
• File tab: Mostly for managing the File Manager itself.
Like closing the File Explorer or opening a new
window.
• Home tab: Is really the main work area and does all
the functions listed at the beginning of this slide show.
• Share tab: Exactly what it says. Emailing, printing,
creating zip files, burning to disc and more.
• View tab: Doesn’t change any file or folder. Only
changes the way you view them and see their
information.
Address bar: Contains the path to the file and folder
selected in the Navigation Pane. The path on a computer
is the internal computer version of a UNC in a web
browser. Windows now allows you to click on a path
segment and the File Explorer will go to that folder.
Navigation Pane: Allows you to navigate from one
folder or location to another. You can pin locations to the
Quick Access area of the Navigation Pane. Other
locations can be on this PC, network locations or One
Drive or another synced cloud location.
Folder Pane: Shows the content of the folder selected in
the Navigation Pane.

Files vs. Shortcuts
Actual file:

Shortcut to file:

Windows File Management Tips
Right-clicking on selected objects:
Always produces a context menu.

Dragging and dropping an object:
Moves the object.

Control-Dragging and dropping an object:
Copies the object.

Moving files on a computer or a web site, breaks the
shortcuts and hyperlinks from other files

What are file extensions?
The two, three or four letters after the filename.
Changing the extension, changes the application.
Opening a file by double-clicking is called document
centric.
Opening a file from within an application is called
application centric.

The icon used for an actual file is slightly different than a
shortcut to a file. Shortcuts have a small blue arrow in
the lower left corner of the icon.
This is an important distinction and has often led to
accidental file deletion. One reason that the Recycle Bin
is a good idea is that you can always open it to recover
deleted files. That is until you empty it.

• When an object is highlighted, the context menu
produced by right-clicking has only commands that
are available for the selected object.
• Dragging and dropping is an easy method of file
moving or copying, but you need to be careful and
read the pop ups under your cursor to be sure where
you are moving or copying. Many IT support people
have spent time locating files that were dropped
incorrectly network drives for large companies.
• Dragging and dropping while holding down the
control key copies the object.
• Whether on a computer or a website, moving a file or
folder will break any links to it. Some web
development software can find and fix broken links.

• The letters after the period in a filename are called the
file extension.
• The file extension tells the OS what application to use
to open the file. A file with an extension of .pdf will be
opened by Adobe Reader or whatever default PDF
program is installed. Likewise, if a document has an
extension of .docx it will open in Microsoft Word. If
you change the file extension, you will get an OS
warning that the file may not open after the extension
has been changed.
• When you use document centric, you double-click a
file and the OS opens using the extension to find the
application.
• When you use application centric, you are working
within an application and you go to File > Open to
open to locate a compatible file.

Creating files:
Always use the application centric method.
Within the application:
1.
2.
3.
4.
5.

Go to File > New to create new, unnamed file
Go to File > Save or Save As
Navigate to your desired location
Name the document.
Click Save.

Creating folders:
Use File Explorer to create folders.
1.
2.
3.
4.
5.
6.

From the Navigation Pane
Go to the desired folder or location.
Go to the Home tab.
Click the New Folder icon.
Name the folder.
Press Enter.

Renaming files and folders:

Using File Explorer
1.
2.
3.

Select the file or folder.
Click the Home tab.
Click Rename and type the new name.

For files leave the extension as is.

Alternate method: Right-click the selected file and
choose Rename.
Another method: Select the file and then click it
once and type the new name.

Copying files or folders:
Using File Explorer.
1.
2.
3.
4.

Select the file or folder to copy
Go to the Home tab.
Click the Copy to icon.
Choose a folder from the list or click Choose location
to find another location.

Alternate method: Control-Drag & Drop to the desired
folder.
Another method: Right-click on the object and choose
Copy. Go to the desired location and right-click a blank
area in the folder and choose Paste.

Moving files or folders:
Using File Explorer.
1.
2.
3.
4.

Select the file or folder to move
Go to the Home tab.
Click the Move to icon.
Choose a folder from the list or click Choose location
to find another location.

Alternate method: Drag & Drop to the desired folder.
Another method: Right-click on the object and choose
Cut. Go to the desired location and right-click a blank
area in the folder and choose Paste.

Deleting files or folders:
Using File Explorer.
1.
2.
3.

Select the file or folder to Delete
Go to the Home tab.
Click the Delete icon.

Alternate method: Select the file or folder and press the
Delete key.
Another method: Right-click on the object and choose
Delete.
Always delete to the Recycle Bin. Permanently
deleting files is not wise.

